Constantly fighting VSCode

Hi all,

I’m having an infuriating time using VSCode recently, I am currently working my way through the RPG Course (currently working on the combat section) and I feel like i’m fighting VSCode the whole way.

For example, VSCode keeps throwing errors such as, when implementing the IAction and ActionScheduler.cs script, it keeps giving me the error which (Sam addresses in the lecture), I implement the fix as instructed but it doesn’t go away, I have to close VSCode and reopen it in order to clear the error.

This is happening with various different things throughout each lecture and it making it impossible for me to see if it’s an error on my behalf or if it’s VSCode deciding it doesn’t want to work with me, therefore I am constantly having to close VSCode and open it again (which isn’t a massive task, but if I have to do this all the time in order to troubleshoot it’s getting frustrating).

Has anyone else had similar issues with VSCode, is there anything I can do to rectify this (restart certain system processes, add or reinstall certain packages etc) ? My VSCode is up to date (on the latest version - 1.5.2).

Many thanks,

Unfortunately, VS Code has not been as friendly to Unity as it was when the decision was made to steer students towards it.

A few things students have done to make things work (but these same things haven’t always helped other students)

  • Making sure VS Code is up to date… (conversely, others have had success rolling it back)
  • Making sure the VS Code plugin in Unity is up to date (Package Manager). (Conversely, others have had success rolling this back).
  • Go into Editor/Preferences/External Tools in Unity. Check any of the boxes for generating various things with the project and click Generate Project files. Uncheck those boxes and Generate the Project files again.

Thanks Brian, I have made sure all VSCode side of things is up to date, I will update VSCode stuff in Unity and have also Generated Project Files (as per your recommendation of with all checked, then again with all unchecked), I will see how it goes :smiley: Thanks again for the information, much appreciated.