Castle Kingdoms MegaPack NavMesh


I recently began using the Castle Demo supplied with the Unity MegaPack. I can’t seem to get the NavMesh features to work with the Castle Demo environment. Each time I press the BAKE button, the ground does not turn BLUE as expected. I’ve check GIZMO, STATIC, so far. Is there anything else I can check?


@Marc_Carlyon, could you help with this problem?

Hi @whodges007

I’m not sure why it is not displaying for you as i’ve just tried it and its working fine for me.
I am also not sure what files are provided in the asset download as we have quite a few on our internal storage.

Heres the process i used.

  1. Open a project in 2022 unity
  2. Install AI Navigation from the package manager
  3. Open the (UNITY)_Castle_Megapack_GDTV.unitypackage and import it into the project
  4. Set the ground to be static
  5. Go to AI → Navigation Obsolete (This is due to them updating to baking at runtime now with Navmesh.Bake() (If i remember correctly))
  6. Bake the Navmesh and it should appear

The ONLY thing i can think of is that the check box in the scene view for displaying the navmesh is turned off.
It wont be anything under the Gizmos as you cant actually turn off the visibility of a baked navmesh there as there is not an option and only turning off the main gizmo visibility does that.
It used to be that you do have to have the navigation window open and active but that does not appear to be the case anymore

If you need further help please do let us know and post some screenshots with the version of unity you are using. (You can use Win Key, Shift and S to bring up a cursor to draw a box around unity and then just control and V that into the reply window)

Good luck :slight_smile:

Privacy & Terms