Camera going weird!


In the lecture,my camera goes completely berserk.The subject doesn’t come into the field and the grid gets distorted,sees another cam through the cam etc.

Its all normal till i press Num pad 0.


1 Like

Your camera is stretched, so you probably changed the camera lens options!

You could delete the camera and add a fresh new one?

Or fiddle the camera options …

Or go in active camera mode (numpad 0) and move rotate the scene.

1 Like

You seem only to have one camera.
So, is it that you are pressing 0 twice and that reverts out of camera view back to the view you were in before?

You have drawn a viewport render box in the top image. Are you expecting the camera view to reflect that? It won’t. It is its own restricted view on what to render in effect.

The grid 'distortion looks just perspective view.


Thanks for the response.No i didnt play around with the lens options.The last thing i did before this happened was disabling the placeholder in the rendered view.

I tried deleting this and adding a new cam as well.Didn’t solve it.The new cam came with the same issue.

yeah i tried moving the camera around using the Num0 and using the walk in method of nav(which is my go to method) and doing that it just spins pivoting at some random point.Also the grid gets distorted,sees another cam aswell and the subject(the bowling pin) is nowhere to be seen!

Thanks for the response!

No, not pressing the Num pad 0 twice.It happens only within the cam view.Yeah it looks like normal perspective in this particular picture i posted,just moving around(in walk-in nav mode after pressing Num0) a little more will bring in the heavily distorted view.Ill try posting a screenshot of it.

And i tried deleting the cam and adding a new one as well,didnt work,same prob.

I added the viewport render box in the outliner thinking it will help me disable those unchecked from appearing in the rendered output image.Is that not the case?

1 Like

@FedPete @NP5 Guys,I think i figured it out,

The problem was that I pressed CTRL+NUM 0 at some point which set the current object as the camera,which explains why I could see everything else except the object and could see the original camera as well .

Thanks a lot for the response!

1 Like

Thanks for letting us know. How odd that another object can be set as the camera. A glitch to try to remember!


Actually @NP5, I had that happen once quite a while ago with an older Blender 2.7 version than the 2.79b I’m currently using. I couldn’t for the life of me figure out how to undo it, once I realized what had happened.

Now-a-days I always work with 2 cameras, and leave the default camera alone.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.