Blueprint Runtime Error Crypt Level polish

I got an error while trying to get the gate to move with the statue. i followed along so I’m not sure where the error came from. Let me know what code I may need to look at again thanks.

Blueprint Runtime Error: “Accessed None trying to read property CallFunc_GetComponentByClass_ReturnValue_1”. Node: Set Mover Graph: EventGraph Function: Execute Ubergraph New Dungeon Blueprint: NewDungeon

Could you show your blueprint please?

This is my main Level BP.

And SM_Crypt_Wall_Plaster5 has a Mover component on it?

Ya i got it on there.

wallMover

Sorry I think I read that incorrectly. Does SM_Statue_Hooded have a trigger component?

I thought the base needs the trigger and the statue has the tag. When i put a trigger on the stature it only worked when I changed the statue to the stand in BP. Why do the both need a trigger? the smaller statue in the earlier lessons did not need it to work.

What do you mean both need the trigger?

  • The stand has a trigger component.
  • The statue has a tag.
  • The gate has a mover component.

Ya I have a trigger on the stand and statue. Also a mover on the wall. It didn’t work when I added the trigger to the statue that wasn’t originally there. It worked when I changed it in the BP to the stand. It seems weird though because if I remove one trigger neither work.

It seems to be working fine now but I am not sure if will cause an issue in the future.

Not working how? Resulting in the error in the OP?

I wasn’t getting an error which was weird the wall just didn’t move. The tags where there and matched as well. When I get off work I plan to mess with it more.