Blender - Unity Troubles?

Hello Guys,

I am a Unity guy and in the course I am in we have to design a little scene basically just a mock-up and I realized what I want to do can’t be done with Unity Primitives…

So, I created a little Blender file, something I have never done before, with just a plane with a cylinder to cut out a hole in the middle - deleted the cylinder and extruded the plane. I then exported the resulting thingy as an FBX and imported it into Unity and when i did I got the following error:

Failed to extract collision data: Submesh 1 uses unsupported primitive type “Quads”.
Please use either “TriangleStrip” or “Triangles”. Please make sure you have unchecked “Keep Quads” on your model’s Import Settings. Mesh asset path “” Mesh name "Plane"

And I have no idea how to correct that … completely lost. And apart from the above to File does not look anything like it does in Blender - probably because of the error.

So any help would be greatly appreciated.


Sorry Guys,

I figured it out :blush:. The tutorial I was using used a Plane, so I tried it again, using a cube instead and it worked this time. My 3rd person character even managed to slide down threw the hole - yay!!!


Privacy & Terms