Ball doesn't launch after mouse click

VERSION
I’m using Unity 5.6.1f1 version.

PROBLEM
The problem I face here is, as my title says, that my ball doesn’t launch after I click my mouse button, but it freezes, there’s no gravity pulling it and stops follow my paddle. But I can still move my paddle so the game keeps working.

1)Already tried to delete my GameObject (ball.png) and my script (ball.cs) and recreate them.
2)Update class runs smoothly (checked with many print() at all stages and ifs).
3)Tried to close and reopen Unity, no luck.
4)Ball’s and Paddle’s Colliders doesn’t contact its other.

Code:
https://pastebin.com/dpvDHttf

PrintScreen of ball’s properties:
http://prntscr.com/fibr9v

PrintScreen of the problem:
http://prntscr.com/fibs2b

Hope a second pair of eyes will find my mistake! :slight_smile:

Thanks in advance!

After some hours of rest, I found my mistake! I unchecked by mistake the “Simulated” property from Rigidbody2D from my Ball… it needs to be checked on both ball and paddle! :grin:

http://prntscr.com/fiez27

So a good advice is, when something doesn’t work, simple delete it and start over! :cold_sweat:

Privacy & Terms